<!DOCTYPE html><html lang="en"><head><meta charset="utf-8"/><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no"/><link rel="canonical" href="https://www.click2houston.com/houston-life/2021/03/29/comedian-michael-yo-coming-home-to-houston-to-headline-shows-at-the-improv/"/><link rel="amphtml" href="https://www.click2houston.com/houston-life/2021/03/29/comedian-michael-yo-coming-home-to-houston-to-headline-shows-at-the-improv/?outputType=amp"/><title>Comedian Michael Yo coming home to Houston to headline shows at the Improv</title><link rel="dns-prefetch" href="graham-kprc.zeustechnology.com"/><link rel="dns-prefetch" href="securepubads.g.doubleclick.net"/><link rel="dns-prefetch" href="static.doubleclick.net"/><link rel="dns-prefetch" href="ib.adnxs.com"/><link rel="dns-prefetch" href="bidder.criteo.com"/><link rel="dns-prefetch" href="static.criteo.net"/><link rel="dns-prefetch" href="as-sec.casalemedia.com"/><link rel="dns-prefetch" href="js-sec.indexww.com"/><link rel="dns-prefetch" href="graham-d.openx.net"/><link rel="dns-prefetch" href="hbopenbid.pubmatic.com"/><link rel="dns-prefetch" href="fastlane.rubiconproject.com"/><link rel="dns-prefetch" href="ap.lijit.com"/><link rel="dns-prefetch" href="s.amazon-adsystem.com"/><link rel="dns-prefetch" href="tagan.adlightning.com"/><link rel="dns-prefetch" href="tpc.googlesyndication.com"/><link rel="dns-prefetch" href="www.googletagservices.com"/><link rel="dns-prefetch" href="fonts.googleapis.com"/><link rel="dns-prefetch" href="cdn.viafoura.net"/><link rel="dns-prefetch" href="ak.sail-horizon.com"/><link rel="dns-prefetch" href="kprc-live.gmg.io"/><link rel="dns-prefetch" href="grahammedia.blueconic.net"/><meta property="og:url" content="https://www.click2houston.com/houston-life/2021/03/29/comedian-michael-yo-coming-home-to-houston-to-headline-shows-at-the-improv/"/><meta property="og:title" content="Comedian Michael Yo coming home to Houston to headline shows at the Improv"/><meta property="og:type" content="article"/><meta property="og:description" content="Michael Yo is a host, stand-up comedian and actor who grew up right here in H-Town."/><meta property="og:image" content="https://www.click2houston.com/resizer/s3osh1QAZE0nFwzst_cdR0po9do=/1600x900/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/MMNVUSXZFBCJ5HHWJ7UC4VCCJA.png"/><meta property="og:site_name" content="KPRC"/><meta property="og:locale" content="en_US"/><meta property="article:published_time" content="2021-03-29T15:15:59.227Z"/><meta property="article:modified_time" content="2021-03-29T15:44:19.462Z"/><meta property="article:section" content="Houston Life"/><meta property="article:tag" content="Events"/><meta property="article:content_tier" content="free"/><meta property="article:opinion" content="false"/><meta name="type" value="article"/><meta name="keywords" content="Events"/><meta name="content_id" content="IANT2SUBZVFH3KNANRCYPIQSLQ"/><meta name="author" content="Erin Montoya"/><meta name="description" content="Michael Yo is a host, stand-up comedian and actor who grew up right here in H-Town."/><meta name="section_path" content="/houston-life"/><meta name="station" content="KPRC"/><meta name="line_count"/><meta name="word_count"/><meta name="inch_count"/><meta name="sailthru.author" content="Erin Montoya"/><meta name="sailthru.title" content="Comedian Michael Yo coming home to Houston to headline shows at the Improv"/><meta name="sailthru.description" content="Michael Yo is a host, stand-up comedian and actor who grew up right here in H-Town."/><meta name="sailthru.tags" content="Events"/><meta name="sailthru.date" content="2021-03-29T15:44:19.462Z"/><meta name="sailthru.image.full" content="https://www.click2houston.com/resizer/s3osh1QAZE0nFwzst_cdR0po9do=/1600x900/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/MMNVUSXZFBCJ5HHWJ7UC4VCCJA.png"/><meta name="sailthru.image.thumb" content="https://www.click2houston.com/resizer/HpTSm3_e1Z1m5zbEl2RGVVF_OAc=/380x213/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/MMNVUSXZFBCJ5HHWJ7UC4VCCJA.png"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:title" content="Comedian Michael Yo coming home to Houston to headline shows at the Improv"/><meta name="twitter:description" content="Michael Yo is a host, stand-up comedian and actor who grew up right here in H-Town."/><meta name="twitter:site" content="KPRC"/><meta name="twitter:image" content="https://www.click2houston.com/resizer/s3osh1QAZE0nFwzst_cdR0po9do=/1600x900/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/MMNVUSXZFBCJ5HHWJ7UC4VCCJA.png"/><meta name="twitter:domain" content="https://www.click2houston.com"/><meta property="fb:app_id" content="111452835671872"/><meta name="vf:unique_id" content="IANT2SUBZVFH3KNANRCYPIQSLQ"/><meta property="al:ios:url"/><meta property="al:ios:app_store_id" content="426130673"/><meta property="al:ios:app_name" content="click2houston.com"/><meta property="al:android:url"/><meta property="al:android:package" content="com.ibsys.app.pns_hou"/><meta property="al:android:app_name" content="click2houston.com"/><meta name="vf:topic" content="EVENTS"/><script src="https://cdn.blueconic.net/grahammedia.js" async=""></script><link rel="manifest" href="/manifest.json"/><meta name="coid" value="IANT2SUBZVFH3KNANRCYPIQSLQ"/><meta name="type" value="article"/><script type="application/javascript">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=273" defer=""><\/script>')}</script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/engine/react.js?d=273" defer=""></script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=273" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css" href="/pf/dist/components/combinations/default.css?d=273"/><style data-styled="ejmyRS jwWfWW iuCgNM jGaUPv bMdnXy jeceU dZjReU lcFans gUmLqE fSHFbF gDbzdw hdFCPU kqxPWZ gfTpEa nqHSn jJYKhZ gKfpUK jFLeST NUNlW gaQDeE cpLKQO hFUbBF bFUyUp foPsRj jhprQM kjOAeC erWZFU cslqvS dOIBOU dRHmrL gueTsy fHpjyF gAlevS cLGXPz giDUPw edjlNO YdQgG clvcNz idqdOA kQEYap fPmFNi gPRgRI gsgKkI fXQkx jzTiIe gtSZuP lNAtG gvslfO zZFXY jXmjsZ eiHcFe dlxTfY qXBJx hAfQFP hzIQTF hkoIJL fPYIGV kBriVv hcXRtD fVRMgy jcSBbU gqMNFT kBdchC fHPrAR hoXqPa caFKJk bhxoAd iZxAQW igkqGm ifhAez kaPImw jYxsit kzFnFX cZxrFf fiBpxo gvkeHj fLgRBc eAzbIG jtsgeD GyqfN tzeei fIxjgD geIAAj jdBinm kqihUa kjNniI kJmJh jeDXwL bCgwSc dQNexQ hJxlgt hnikHe jfrLJo cHbzHq hYwgMt bCyWJK cSqiGO bhDoLz idDlsb cWpTbe iVNNhU cnsPZT jKvIth eGIiXs izfRRR ewQCSW iztsEa eIMnfT ljkHmN eswnxf cUYiQV ivKcDu eYDkSD dWfAjD bAIuEF bjELSs cqvaFh drzbpJ fThzlo kKEIIQ dwfmEj qIYQl hMgzMl iToFNo cZtdXo bqsGoj bRCfzc eayAjN dUdVZO KmuEL cOXxcV bUJyuH hqjdYc fkPfnZ jFCQYz fbCQVN bPhynQ hObaso bNkNzD bMpCDl bgiycj fJpLJR iLJAuF cGFgHT efLRKi ihrMEN faMlgr bgpVcv llANtS gwxkBP iCCVDB ehxeFc ktXBcW MiOUz fLEDfG lhbTOM fSJjpK brALqs cwvhsZ bCCjaw jxpOpo hjiqdU gtetFj dixtml gYLfnR cxHMZc FTPkm dfchQM elRaHF eRVpMB gxyMkv ghjhZl hTpoqt fJxCWQ ehfZJW glXEHH iHStHL kPsagQ fHWxCI dCLOcD knLpnw eQjQh iJLGvg dSOlzQ gqqRuu fKkgAk PwHLz bDvyee gpyNji kIQwDb enovIt csmNby ylsvi hyblkX kLGAiz bPweVN gipVYl eWxIgu vWBZS gQHKfs hUCeMK cQtTJu lawncY kcAtDt fTWKba evlRrf kZgoCE djyEOW hdyfKU gdojKS cBayCs djMVlM iYxBjb fFEWue kPVPRT dgkUkq AkcLs sTGfI eGALCq QNoux kYCUNl fvHwPQ kUckCV eElnts bNqaKe iOAUzh bAtFBP bzOWvD haduDX dbkKBB liazok eoWsvz IxIhx hvnGGT vvuqy cbWPlM ecuNbI dJiOVq jFgmSC kvtnlw fFWmJ jCEkSM fBaDaf dRMzTN kxdhCj boakWX JMwsD keiTHn jopcKp gHdyxm khswYN cMMtrq bdrOSW cwveGZ jguRJQ dFaPof hRQMby gpipuI hnYTzv fdlVFt eUMBLR dUVMcR knDzLX dEycVv jWxIsE cOJnWb fymcmx bOiIhQ hjicFx eGZayg eOvCBo gNGDqS" data-styled-version="4.4.1">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</style><style>.async-hide { opacity: 0 !important}</style><script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
    h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
    (a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
    })(window,document.documentElement,'async-hide','dataLayer',4000,
    {'GTM-NMDW6PD':true});</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-17717613-1', 'auto', {'useAmpClientId':true});
    ga('require', 'GTM-NMDW6PD');</script><script async="" src="https://www.googletagmanager.com/gtm/js?id=GTM-NQDG22W"></script><script>if (window) { window.dataLayer = window.dataLayer || [];
    window.dataLayer.push(
      {"siteId": "KPRC",
      'event':'gtm.js'
      }
    )}</script><script type="application/ld+json">{"@context":"https://schema.org","@type":"Article","headline":"Comedian Michael Yo coming home to Houston to headline shows at the Improv","description":"Michael Yo is a host, stand-up comedian and actor who grew up right here in H-Town.","url":"https://www.click2houston.com/houston-life/2021/03/29/comedian-michael-yo-coming-home-to-houston-to-headline-shows-at-the-improv/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.click2houston.com/houston-life/2021/03/29/comedian-michael-yo-coming-home-to-houston-to-headline-shows-at-the-improv/"},"image":{"@type":"ImageObject","url":"https://www.click2houston.com/resizer/HpTSm3_e1Z1m5zbEl2RGVVF_OAc=/380x213/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/MMNVUSXZFBCJ5HHWJ7UC4VCCJA.png","name":"Comedian and Houston native Michael Yo","width":300,"height":168},"datePublished":"2021-03-29T15:15:59.227Z","dateModified":"2021-03-29T15:44:19.462Z","publisher":{"@type":"Organization","name":"KPRC Click2Houston","logo":{"@type":"ImageObject","url":"https://t.gmg.io/amp/search/kprc.png","name":"KPRC2 & Click2Houston.com"}},"author":[{"@type":"Person","name":"Erin Montoya","sameAs":"https://www.click2houston.com/team/T764W47KTBHRFF7WHTW5NSKTDA"}],"articleSection":"Houston Life","mentions":[{"@type":"Thing","name":"Events","url":"https://www.click2houston.com/topic/Events/"}],"keywords":["Events"]}</script><script src="/pf/resources/dist/kprc/js/index.js?d=273"></script><link rel="stylesheet" href="/pf/resources/dist/kprc/css/style.css?d=273"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/kprc/favicon.ico?d=273"/><script src="https://tagan.adlightning.com/grahammedia/op.js" defer=""></script><script src="https://c.amazon-adsystem.com/aax2/apstag.js" async=""></script><script>
    window.gmgAdUnitPath = "/15466288/KPRC/Web/houston-life";
    window.zeusKeyvalues = {
      tags: "Events",
      type: "article",
      coid: "IANT2SUBZVFH3KNANRCYPIQSLQ"
    };
  </script><script src="https://graham-KPRC.zeustechnology.com/main.js" async="" id="__zeus_script"></script>
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-c9fe4d22-8c14-4bb0-8ae3-95bf93ebb391","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"","rua.texp":""}]);</script>
                          <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="A6P98-85PHS-FT5MF-G7NHM-6DNMS",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"A6P98-85PHS-FT5MF-G7NHM-6DNMS",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubax2t5jaydb666q-f-c3a8f3bf7-clientnsv4-s.akamaihd.net",i={"ak.v":"31","ak.cp":"890241","ak.ai":parseInt("569003",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"faeda7e","ak.r":41489,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":39314,"ak.gh":"23.220.106.144","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1617033149","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==dzRJdM0p+LlE6LzXXt9Z2/Yi5kX8qSDUAssTb2g6xumIRGvYmqGq6/EeMHzBlxKdJ1YKwQlQ6drIg6/zrygDVtOaKC0j60BK/cvvdUQHdhXAzceq1I7xVES5q20AH0QvrzZskvcC7mK0g/09F66OkF4J0gNBWlD2MXc8PIIUexczrlNXurVEP6tdRsVbYPKmeI2g4/r+bA30SoSQiZ6qR1L7Pcvi+XpjoyJsazR6qHr0m1szkuKIgnyYDYVXCgdqGO2f0oecMze1Qpz5RK5iLZB0xhusxsrxEoEt7XBj/ZV09zWP+VDuUH4N7NENez4nvbOY7EEOfC9YVvD/UPPKr/OvIoJS0xeE/5RfahKMs0WgvZDSVpMmI/SGkCzFZiRlN+A2nfv3ecJa63MFteoOV0clNk4pVcEwiZcSALo2f9w=","ak.pv":"15","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body class="" data-station="kprc"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NQDG22W" height="0" width="0" style="display:none;visibility:hidden" title="GTM"></iframe></noscript><div id="fusion-app"><header class="Box-sc-12ejyki-0 gvkeHj"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 gDbzdw headerWrapper"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 hdFCPU container"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 kqxPWZ left"><div class="Box-sc-12ejyki-0 fLgRBc pointer"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="bars" class="svg-inline--fa fa-bars fa-w-14 fa-fw " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"></path></svg></div><a href="/weather/" class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 dOIBOU weather"><figure class="Box-sc-12ejyki-0 fbCQVN"><div class="Box-sc-12ejyki-0 bPhynQ imageWrapper"><img decoding="async" src="https://t.gmg.io/weather/widgets/32.svg" alt="photo"/></div></figure><div class="Box-sc-12ejyki-0 hObaso"><span class="Text__BaseText-mmkwcw-0 kxdhCj">64<span class="Text__BaseText-mmkwcw-0 kxdhCj">º</span></span></div></a></div><div class="Box-sc-12ejyki-0 gxyMkv logo gaevent"><a href="/houston-life/" gacategory="Nav" gaaction="Home" galabel="/"><img src="https://t.gmg.io/header/houston-life.svg" alt="kprc logo"/></a></div><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 nqHSn right"><div class="Box-sc-12ejyki-0 tzeei"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="user" class="svg-inline--fa fa-user fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M224 256c70.7 0 128-57.3 128-128S294.7 0 224 0 96 57.3 96 128s57.3 128 128 128zm89.6 32h-16.7c-22.2 10.2-46.9 16-72.9 16s-50.6-5.8-72.9-16h-16.7C60.2 288 0 348.2 0 422.4V464c0 26.5 21.5 48 48 48h352c26.5 0 48-21.5 48-48v-41.6c0-74.2-60.2-134.4-134.4-134.4z"></path></svg></div><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 jJYKhZ"><button class="Box-sc-12ejyki-0 Button__BaseButton-sc-11k3sle-0 bNqaKe"><span class="Text__BaseText-mmkwcw-0 ecuNbI">Join Insider</span><div class="Box-sc-12ejyki-0 fIxjgD"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="lock-alt" class="svg-inline--fa fa-lock-alt fa-w-14 fa-fw " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 224h-24v-72C376 68.2 307.8 0 224 0S72 68.2 72 152v72H48c-26.5 0-48 21.5-48 48v192c0 26.5 21.5 48 48 48h352c26.5 0 48-21.5 48-48V272c0-26.5-21.5-48-48-48zM264 392c0 22.1-17.9 40-40 40s-40-17.9-40-40v-48c0-22.1 17.9-40 40-40s40 17.9 40 40v48zm32-168H152v-72c0-39.7 32.3-72 72-72s72 32.3 72 72v72z"></path></svg></div></button><button class="Box-sc-12ejyki-0 Button__BaseButton-sc-11k3sle-0 kUckCV"><span class="Text__BaseText-mmkwcw-0 ecuNbI">Sign In</span><div class="Box-sc-12ejyki-0 fIxjgD"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="user" class="svg-inline--fa fa-user fa-w-14 fa-fw " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M224 256c70.7 0 128-57.3 128-128S294.7 0 224 0 96 57.3 96 128s57.3 128 128 128zm89.6 32h-16.7c-22.2 10.2-46.9 16-72.9 16s-50.6-5.8-72.9-16h-16.7C60.2 288 0 348.2 0 422.4V464c0 26.5 21.5 48 48 48h352c26.5 0 48-21.5 48-48v-41.6c0-74.2-60.2-134.4-134.4-134.4z"></path></svg></div></button></div><div class="viafoura"><vf-tray-trigger floating="false" style="display:none"></vf-tray-trigger></div></div></div></div><div class="Box-sc-12ejyki-0 bNkNzD burgerMenu transition-100"><div class="Box-sc-12ejyki-0 bMpCDl"><div class="Box-sc-12ejyki-0 bgiycj"><div class="Box-sc-12ejyki-0 fJpLJR"><form action="/search/" class="" id="navSearch" method="get" name="" role="search"><div class="Box-sc-12ejyki-0 kaPImw inputWrapper"><input type="text" id="navSearchInputBox" name="searchTerm" placeholder="Search for anything..." value="" class="Box-sc-12ejyki-0 Input__BaseInput-qwik9t-0 gNGDqS"/></div><button class="btn font_gibson transition-100 display_none font_semibold blue" name="" type="submit" value="">Search</button></form></div></div><nav class="Box-sc-12ejyki-0 bgiycj navItems"><ul class="Box-sc-12ejyki-0 iLJAuF"><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 ihrMEN gaevent"><a href="https://www.click2houston.com/" gacategory="Nav" gaaction="Hamburger Primary" galabel="https://www.click2houston.com/"><strong>Click2Houston</strong></a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 ihrMEN gaevent"><a href="/houston-life/2019/10/10/seen-on-houston-life/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/houston-life/2019/10/10/seen-on-houston-life/"><strong>Seen On Houston Life</strong></a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 ihrMEN gaevent"><a href="/houston-life/2019/12/20/learn-more-about-kprc-2s-afternoon-lifestyle-show-houston-life/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/houston-life/2019/12/20/learn-more-about-kprc-2s-afternoon-lifestyle-show-houston-life/"><strong>About Us</strong></a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 ihrMEN gaevent"><a href="/houston-life/2019/12/20/want-to-be-featured-on-houston-life-heres-how/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/houston-life/2019/12/20/want-to-be-featured-on-houston-life-heres-how/"><strong>Be On The Show</strong></a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 ihrMEN gaevent"><a href="/houston-life/2020/07/02/be-a-part-of-houston-lifes-wine-club/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/houston-life/2020/07/02/be-a-part-of-houston-lifes-wine-club/"><strong>Wine Club</strong></a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 ihrMEN gaevent"><a href="/things-to-do/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/things-to-do"><strong>Things To Do</strong></a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 ihrMEN gaevent"><a href="/tex/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/tex/"><strong>Follow Tex</strong></a></div></li></ul></li></ul></nav></div></div><nav class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 dRHmrL spotlight"><ul class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 gueTsy"><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="https://www.click2houston.com/" gacategory="Nav" gaaction="Spotlight" galabel="https://www.click2houston.com/">Click2Houston</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/houston-life/2019/10/10/seen-on-houston-life/" gacategory="Nav" gaaction="Spotlight" galabel="/houston-life/2019/10/10/seen-on-houston-life/">Seen On Houston Life</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/houston-life/2019/12/20/learn-more-about-kprc-2s-afternoon-lifestyle-show-houston-life/" gacategory="Nav" gaaction="Spotlight" galabel="/houston-life/2019/12/20/learn-more-about-kprc-2s-afternoon-lifestyle-show-houston-life/">About Us</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/houston-life/2019/12/20/want-to-be-featured-on-houston-life-heres-how/" gacategory="Nav" gaaction="Spotlight" galabel="/houston-life/2019/12/20/want-to-be-featured-on-houston-life-heres-how/">Be On The Show</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/houston-life/2020/07/02/be-a-part-of-houston-lifes-wine-club/" gacategory="Nav" gaaction="Spotlight" galabel="/houston-life/2020/07/02/be-a-part-of-houston-lifes-wine-club/">Wine Club</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/things-to-do/" gacategory="Nav" gaaction="Spotlight" galabel="/things-to-do/">Things To Do</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/tex/" gacategory="Nav" gaaction="Spotlight" galabel="/tex/">Follow Tex</a></div></li></ul></nav><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 fHpjyF transition-300"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 gAlevS container"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 cLGXPz"><div class="Box-sc-12ejyki-0 fLgRBc pointer"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="bars" class="svg-inline--fa fa-bars fa-w-14 fa-fw " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"></path></svg></div><a class="logo" href="/houston-life/"><figure class="Box-sc-12ejyki-0 llANtS"><div class="Box-sc-12ejyki-0 gwxkBP imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:16px" class="lazyload-placeholder"></div></div></figure></a></div><nav class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 giDUPw spotlight"><ul class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 edjlNO"><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="https://www.click2houston.com/" gacategory="Nav" gaaction="MiniBar" galabel="https://www.click2houston.com/" gavalue="0">Click2Houston</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/houston-life/2019/10/10/seen-on-houston-life/" gacategory="Nav" gaaction="MiniBar" galabel="/houston-life/2019/10/10/seen-on-houston-life/" gavalue="1">Seen On Houston Life</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/houston-life/2019/12/20/learn-more-about-kprc-2s-afternoon-lifestyle-show-houston-life/" gacategory="Nav" gaaction="MiniBar" galabel="/houston-life/2019/12/20/learn-more-about-kprc-2s-afternoon-lifestyle-show-houston-life/" gavalue="2">About Us</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/houston-life/2019/12/20/want-to-be-featured-on-houston-life-heres-how/" gacategory="Nav" gaaction="MiniBar" galabel="/houston-life/2019/12/20/want-to-be-featured-on-houston-life-heres-how/" gavalue="3">Be On The Show</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/houston-life/2020/07/02/be-a-part-of-houston-lifes-wine-club/" gacategory="Nav" gaaction="MiniBar" galabel="/houston-life/2020/07/02/be-a-part-of-houston-lifes-wine-club/" gavalue="4">Wine Club</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/things-to-do/" gacategory="Nav" gaaction="MiniBar" galabel="/things-to-do/" gavalue="5">Things To Do</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/tex/" gacategory="Nav" gaaction="MiniBar" galabel="/tex/" gavalue="6">Follow Tex</a></div></div></li></ul></nav></div></div></header><section class="Box-sc-12ejyki-0 kaPImw wrapper"><main class="Box-sc-12ejyki-0 geIAAj article" role="main"><section class="Box-sc-12ejyki-0 jdBinm top-wide"><div class="scGrid full-width twoCol" id="0f4QEZVpGrA"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 gKfpUK ssrAdSkeleton" aria-hidden="true"><span class="Text__BaseText-mmkwcw-0 dJiOVq" role="presentation">Ad</span></div></div></section><aside id="article" class="Box-sc-12ejyki-0 kqihUa"><section class="chainGroup" id="0f1VvA1iDrr"><div class="Box-sc-12ejyki-0 kaPImw articleInfo"><div class="Box-sc-12ejyki-0 kjNniI"><h4 class="Header__StyledHeader-qoaq48-0 eUMBLR"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/houston-life" gacategory="Article Rail" gaaction="Section Link" galabel="Houston Life">Houston Life</a></div></h4><hr class="Box-sc-12ejyki-0 Divider-sc-1n9x3vv-0 hjicFx"/></div><div class="Box-sc-12ejyki-0 kJmJh metadata"><div class="Box-sc-12ejyki-0 kjNniI byline"><p class="Text__BaseText-mmkwcw-0 jFgmSC author"><div class="Box-sc-12ejyki-0 jeDXwL gaevent"><a href="/team/T764W47KTBHRFF7WHTW5NSKTDA/" gacategory="Article Rail" gaaction="Author Link" galabel="Erin Montoya" gavalue="0">Erin Montoya</a></div>, Senior Producer, Houston Life</p></div><div class="Box-sc-12ejyki-0 bCgwSc time"><time class="Text__BaseText-mmkwcw-0 kvtnlw" dateTime="2021-03-29T15:15:59.227Z">Published: <span class="Text__BaseText-mmkwcw-0 fFWmJ"><time dateTime="1617030959227" class="">March 29, 2021, 10:15 am</time></span></time><time class="Text__BaseText-mmkwcw-0 kvtnlw" dateTime="2021-03-29T15:44:19.462Z">Updated: <span class="Text__BaseText-mmkwcw-0 fFWmJ"><time dateTime="1617032659462" class="">March 29, 2021, 10:44 am</time></span></time></div><div class="Box-sc-12ejyki-0 dQNexQ tags">Tags: <span class="Text__BaseText-mmkwcw-0 jCEkSM"><div class="Box-sc-12ejyki-0 jXmjsZ"><a href="/topic/Events/" gacategory="Article Rail" gaaction="Tag Link">Events</a></div></span></div></div><hr class="Box-sc-12ejyki-0 Divider-sc-1n9x3vv-0 eGZayg"/></div><div><h5>Sign up for our Newsletters</h5><form action="" class="formField transition-300 mb-med" encType="application/x-www-form-urlencoded" method="GET" name="" role=""><div class="textFieldWrap relative font_openSans font_regular"><input type="email" aria-invalid="false" autoComplete="" class="transition-500 sm" name="email" placeholder="Enter your email here!" value=""/><label class="transition-100 text_left absolute font_gibson font_medium"></label></div></form></div><div id="fusion-static-enter:0faiKp1iDrJ" style="display:none"></div><div class="social-share | display_flex | mb-norm | justify_center | align_items_center"><div class="viafoura"><div class="vf-widget vf-share-bar-circle vf-share-bar-bw" data-widget="sharebar" data-button-view="false" data-show-labels="false" data-show-counters="false" data-show-total="false" data-share-current-page-url="true"></div></div><div class="viafoura"><a class="com-anchor | display_block | color_black" href="#comments"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="comments" class="svg-inline--fa fa-comments fa-w-18 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" style="max-height:1.5rem"><path fill="currentColor" d="M416 192c0-88.4-93.1-160-208-160S0 103.6 0 192c0 34.3 14.1 65.9 38 92-13.4 30.2-35.5 54.2-35.8 54.5-2.2 2.3-2.8 5.7-1.5 8.7S4.8 352 8 352c36.6 0 66.9-12.3 88.7-25 32.2 15.7 70.3 25 111.3 25 114.9 0 208-71.6 208-160zm122 220c23.9-26 38-57.7 38-92 0-66.9-53.5-124.2-129.3-148.1.9 6.6 1.3 13.3 1.3 20.1 0 105.9-107.7 192-240 192-10.8 0-21.3-.8-31.7-1.9C207.8 439.6 281.8 480 368 480c41 0 79.1-9.2 111.3-25 21.8 12.7 52.1 25 88.7 25 3.2 0 6.1-1.9 7.3-4.8 1.3-2.9.7-6.3-1.5-8.7-.3-.3-22.4-24.2-35.8-54.5z"></path></svg><span class="vf-counter vf-widget font_gibson font_semibold" data-widget="counter"></span></a></div></div><hr class="Box-sc-12ejyki-0 Divider-sc-1n9x3vv-0 cOJnWb"/><div id="fusion-static-exit:0faiKp1iDrJ" style="display:none"></div></section><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 jFLeST ssrAdSkeleton" aria-hidden="true"><span class="Text__BaseText-mmkwcw-0 fBaDaf" role="presentation">Ad</span></div><aside id="0fPgeUQdGrU" class="Box-sc-12ejyki-0 hJxlgt"><div class="Box-sc-12ejyki-0 hnikHe"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 jFLeST ssrAdSkeleton" aria-hidden="true"><span class="Text__BaseText-mmkwcw-0 fBaDaf" role="presentation">Ad</span></div><section class="storyList"><h4 class="mb-sm" style="text-transform:uppercase">Latest News</h4><hr class="bold" style="margin-bottom:1rem"/><section class="topic grid textOverlay full-width gap_x_norm gap_y_norm"><div class="grid story-list gap_x_norm gap_y_norm vertical"><article class="storyCard mb-norm"><div class="Box-sc-12ejyki-0 ehxeFc relative min gridItem height_full horizontal"><div class="Box-sc-12ejyki-0 ktXBcW gaevent"><a href="/news/local/2021/03/29/5-things-for-houstonians-to-know-for-monday-march-29/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/5-things-for-houstonians-to-know-for-monday-march-29/" gavalue="0"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 iVNNhU width_full height_full"><div class="Box-sc-12ejyki-0 MiOUz imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></div></a></div><div class="Box-sc-12ejyki-0 fLEDfG articleMeta width_full"><div class="Box-sc-12ejyki-0 lhbTOM time gaevent"><a href="/news/local/2021/03/29/5-things-for-houstonians-to-know-for-monday-march-29/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/5-things-for-houstonians-to-know-for-monday-march-29/" gavalue="0">1 hour ago</a></div><a class="display_block gaevent" href="/news/local/2021/03/29/5-things-for-houstonians-to-know-for-monday-march-29/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/5-things-for-houstonians-to-know-for-monday-march-29/" gavalue="0"><h3 class="no-margin">5 things for Houstonians to know for Monday, March 29</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm"><div class="Box-sc-12ejyki-0 ehxeFc relative min gridItem height_full horizontal"><div class="Box-sc-12ejyki-0 ktXBcW gaevent"><a href="/news/local/2021/03/29/pandemic-pivot-changing-careers-during-a-pandemic/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/pandemic-pivot-changing-careers-during-a-pandemic/" gavalue="1"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 iVNNhU width_full height_full"><div class="Box-sc-12ejyki-0 MiOUz imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></div></a></div><div class="Box-sc-12ejyki-0 fLEDfG articleMeta width_full"><div class="Box-sc-12ejyki-0 lhbTOM time gaevent"><a href="/news/local/2021/03/29/pandemic-pivot-changing-careers-during-a-pandemic/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/pandemic-pivot-changing-careers-during-a-pandemic/" gavalue="1">3 hours ago</a></div><a class="display_block gaevent" href="/news/local/2021/03/29/pandemic-pivot-changing-careers-during-a-pandemic/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/pandemic-pivot-changing-careers-during-a-pandemic/" gavalue="1"><h3 class="no-margin">Pandemic Pivot: Changing careers during a pandemic</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm"><div class="Box-sc-12ejyki-0 ehxeFc relative min gridItem height_full horizontal"><div class="Box-sc-12ejyki-0 ktXBcW gaevent"><a href="/news/local/2021/03/29/american-bully-stolen-from-front-yard-in-broad-daylight-family-offering-reward-for-information/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/american-bully-stolen-from-front-yard-in-broad-daylight-family-offering-reward-for-information/" gavalue="2"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 iVNNhU width_full height_full"><div class="Box-sc-12ejyki-0 MiOUz imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></div></a></div><div class="Box-sc-12ejyki-0 fLEDfG articleMeta width_full"><div class="Box-sc-12ejyki-0 lhbTOM time gaevent"><a href="/news/local/2021/03/29/american-bully-stolen-from-front-yard-in-broad-daylight-family-offering-reward-for-information/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/american-bully-stolen-from-front-yard-in-broad-daylight-family-offering-reward-for-information/" gavalue="2">12 hours ago</a></div><a class="display_block gaevent" href="/news/local/2021/03/29/american-bully-stolen-from-front-yard-in-broad-daylight-family-offering-reward-for-information/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/03/29/american-bully-stolen-from-front-yard-in-broad-daylight-family-offering-reward-for-information/" gavalue="2"><h3 class="no-margin">Family offers reward after American Bully stolen from front yard</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm"><div class="Box-sc-12ejyki-0 ehxeFc relative min gridItem height_full horizontal"><div class="Box-sc-12ejyki-0 ktXBcW gaevent"><a href="/health/2020/03/05/man-woman-confirmed-to-be-first-cases-of-coronavirus-confirmed-in-harris-county/" gacategory="Story Card" gaaction="Story List" galabel="/health/2020/03/05/man-woman-confirmed-to-be-first-cases-of-coronavirus-confirmed-in-harris-county/" gavalue="3"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 iVNNhU width_full height_full"><div class="Box-sc-12ejyki-0 MiOUz imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></div></a></div><div class="Box-sc-12ejyki-0 fLEDfG articleMeta width_full"><div class="Box-sc-12ejyki-0 lhbTOM time gaevent"><a href="/health/2020/03/05/man-woman-confirmed-to-be-first-cases-of-coronavirus-confirmed-in-harris-county/" gacategory="Story Card" gaaction="Story List" galabel="/health/2020/03/05/man-woman-confirmed-to-be-first-cases-of-coronavirus-confirmed-in-harris-county/" gavalue="3">13 hours ago</a></div><a class="display_block gaevent" href="/health/2020/03/05/man-woman-confirmed-to-be-first-cases-of-coronavirus-confirmed-in-harris-county/" gacategory="Story Card" gaaction="Story List" galabel="/health/2020/03/05/man-woman-confirmed-to-be-first-cases-of-coronavirus-confirmed-in-harris-county/" gavalue="3"><h3 class="no-margin">CHART: Track the number of coronavirus cases, recoveries and deaths in the Greater Houston area</h3></a></div></div></article></div></section></section></div></aside></aside><section class="Box-sc-12ejyki-0 jfrLJo mainContent"><div class="Box-sc-12ejyki-0 cHbzHq articleInfo"><h4 class="Header__StyledHeader-qoaq48-0 dUVMcR"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/houston-life" gacategory="Article Rail" gaaction="Section Link" galabel="Houston Life">Houston Life</a></div></h4></div><article class="Box-sc-12ejyki-0 hYwgMt story"><div class="Box-sc-12ejyki-0 bCyWJK"><h1 class="Header__StyledHeader-qoaq48-0 knDzLX headline">Comedian Michael Yo coming home to Houston to headline shows at the Improv</h1><h2 class="Header__StyledHeader-qoaq48-0 dEycVv subheadline">Get your tickets before they sell out! </h2></div><div class="Box-sc-12ejyki-0 cSqiGO metadata"><div class="Box-sc-12ejyki-0 kjNniI byline"><p class="Text__BaseText-mmkwcw-0 jFgmSC author"><div class="Box-sc-12ejyki-0 jeDXwL gaevent"><a href="/team/T764W47KTBHRFF7WHTW5NSKTDA/" gacategory="Article Rail" gaaction="Author Link" galabel="Erin Montoya" gavalue="0">Erin Montoya</a></div>, Senior Producer, Houston Life</p></div><div class="Box-sc-12ejyki-0 bCgwSc time"><time class="Text__BaseText-mmkwcw-0 kvtnlw" dateTime="2021-03-29T15:15:59.227Z">Published: <span class="Text__BaseText-mmkwcw-0 fFWmJ"><time dateTime="1617030959227" class="">March 29, 2021, 10:15 am</time></span></time><time class="Text__BaseText-mmkwcw-0 kvtnlw" dateTime="2021-03-29T15:44:19.462Z">Updated: <span class="Text__BaseText-mmkwcw-0 fFWmJ"><time dateTime="1617032659462" class="">March 29, 2021, 10:44 am</time></span></time></div><div class="Box-sc-12ejyki-0 dQNexQ tags">Tags: <span class="Text__BaseText-mmkwcw-0 jCEkSM"><div class="Box-sc-12ejyki-0 jXmjsZ"><a href="/topic/Events/" gacategory="Article Rail" gaaction="Tag Link">Events</a></div></span></div></div><div class="Box-sc-12ejyki-0 bhDoLz basicStory"><figure class="Box-sc-12ejyki-0 iVNNhU promo full-width"><div class="Box-sc-12ejyki-0 kYCUNl imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:1080px" class="lazyload-placeholder"></div></div><figcaption class="Box-sc-12ejyki-0 eGIiXs"><span class="Text__BaseText-mmkwcw-0 kxdhCj">Comedian and Houston native Michael Yo</span><span class="Text__BaseText-mmkwcw-0 kxdhCj"> (Copyright 2021 by KPRC Click2Houston - All rights reserved.)</span></figcaption></figure><section class="Box-sc-12ejyki-0 cWpTbe articleBody" itemProp="articleBody"><div class="mobileOnly"><div class="social-share | display_flex | mb-norm | justify_center | align_items_center"><div class="viafoura"><div class="vf-widget vf-share-bar-circle vf-share-bar-bw" data-widget="sharebar" data-button-view="false" data-show-labels="false" data-show-counters="false" data-show-total="false" data-share-current-page-url="true"></div></div><div class="viafoura"><a class="com-anchor | display_block | color_black" href="#comments"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="comments" class="svg-inline--fa fa-comments fa-w-18 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" style="max-height:1.5rem"><path fill="currentColor" d="M416 192c0-88.4-93.1-160-208-160S0 103.6 0 192c0 34.3 14.1 65.9 38 92-13.4 30.2-35.5 54.2-35.8 54.5-2.2 2.3-2.8 5.7-1.5 8.7S4.8 352 8 352c36.6 0 66.9-12.3 88.7-25 32.2 15.7 70.3 25 111.3 25 114.9 0 208-71.6 208-160zm122 220c23.9-26 38-57.7 38-92 0-66.9-53.5-124.2-129.3-148.1.9 6.6 1.3 13.3 1.3 20.1 0 105.9-107.7 192-240 192-10.8 0-21.3-.8-31.7-1.9C207.8 439.6 281.8 480 368 480c41 0 79.1-9.2 111.3-25 21.8 12.7 52.1 25 88.7 25 3.2 0 6.1-1.9 7.3-4.8 1.3-2.9.7-6.3-1.5-8.7-.3-.3-22.4-24.2-35.8-54.5z"></path></svg><span class="vf-counter vf-widget font_gibson font_semibold" data-widget="counter"></span></a></div></div></div><p class="Text__BaseText-mmkwcw-0 dRMzTN"><strong>HOUSTON</strong> – Michael Yo is a host, stand-up comedian and actor who grew up right here in H-Town. He’s heading back to the Bayou City this week to bring the laughs for audiences at the Houston Improv.</p><div class=""><div><iframe src="https://giphy.com/embed/65UFL41CLeTRQWztXt" width="480" height="480" frameBorder="0" class="giphy-embed" allowFullScreen></iframe><p><a href="https://giphy.com/gifs/brownsugarapp-running-hurry-michael-yo-65UFL41CLeTRQWztXt">via GIPHY</a></p></div></div><p class="Text__BaseText-mmkwcw-0 dRMzTN">Michael is one of our favorite guests on the show, and is always up for anything we throw his way.</p><div class=""><div><iframe width="560" height="315" src="https://www.youtube.com/embed/uvz8Y2CDY_0" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div><p class="Text__BaseText-mmkwcw-0 dRMzTN">He has five performances coming up at the Houston Improv. For tickets and more information, click <a href="https://improvtx.com/houston/comic/michael+yo/" target=_blank>here</a>.</p><p class="Text__BaseText-mmkwcw-0 dRMzTN">You can catch Michael on <a href="https://www.click2houston.com/houston-life/" target=_blank>Houston Life</a> this Thursday at 3 p.m. on KPRC 2.</p></section><p class="Text__BaseText-mmkwcw-0 JMwsD copyright">Copyright 2021 by KPRC Click2Houston - All rights reserved.</p><hr class="Box-sc-12ejyki-0 Divider-sc-1n9x3vv-0 cOJnWb"/></div></article><div class="scGrid full-width oneCol" id="0fI31iIuLro"></div><div id="bio" class="display_flex column mb-lg"><h4 class="uppercase">About the Author:</h4><div class="author-container display_flex column"><div class="Box-sc-12ejyki-0 ewQCSW author" itemscope="" itemType="http://schema.org/Person" itemProp="author"><figure class="Box-sc-12ejyki-0 iVNNhU rounded-full"><div class="Box-sc-12ejyki-0 eswnxf imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:86px" class="lazyload-placeholder"></div></div></figure><div class="authorInfo display_flex column"><h5 class="font_semibold no-margin"><a class="font_gibson font_semibold link blue" itemProp="url" href="/team/T764W47KTBHRFF7WHTW5NSKTDA"><span itemProp="name">Erin Montoya</span></a></h5><p class="font_openSans mb-sm">Erin Montoya is an award-winning producer, middle child and mom of two boys. </p><div class="author-social display_flex row color_blue"><a href="mailto:emontoya@kprc.com?subject=Re:Comedian Michael Yo coming home to Houston to headline shows at the Improv" class="mr-norm link blue display_flex align_items_center"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="envelope" class="svg-inline--fa fa-envelope fa-w-16 mr-xsm" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" style="font-size:0.875rem;max-height:0.875rem"><path fill="currentColor" d="M502.3 190.8c3.9-3.1 9.7-.2 9.7 4.7V400c0 26.5-21.5 48-48 48H48c-26.5 0-48-21.5-48-48V195.6c0-5 5.7-7.8 9.7-4.7 22.4 17.4 52.1 39.5 154.1 113.6 21.1 15.4 56.7 47.8 92.2 47.6 35.7.3 72-32.8 92.3-47.6 102-74.1 131.6-96.3 154-113.7zM256 320c23.2.4 56.6-29.2 73.4-41.4 132.7-96.3 142.8-104.7 173.4-128.7 5.8-4.5 9.2-11.5 9.2-18.9v-19c0-26.5-21.5-48-48-48H48C21.5 64 0 85.5 0 112v19c0 7.4 3.4 14.3 9.2 18.9 30.6 23.9 40.7 32.4 173.4 128.7 16.8 12.2 50.2 41.8 73.4 41.4z"></path></svg><span class="font_gibson font_medium color_blue">email</span></a><a href="https://https://www.facebook.com/HoustonLifeTV/" class="mr-norm link blue display_flex align_items_center"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="facebook-square" class="svg-inline--fa fa-facebook-square fa-w-14 mr-xsm" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512" style="font-size:0.875rem;max-height:0.875rem"><path fill="currentColor" d="M400 32H48A48 48 0 0 0 0 80v352a48 48 0 0 0 48 48h137.25V327.69h-63V256h63v-54.64c0-62.15 37-96.48 93.67-96.48 27.14 0 55.52 4.84 55.52 4.84v61h-31.27c-30.81 0-40.42 19.12-40.42 38.73V256h68.78l-11 71.69h-57.78V480H400a48 48 0 0 0 48-48V80a48 48 0 0 0-48-48z"></path></svg><span class="font_gibson font_medium color_blue">facebook</span></a><a href="https://www.instagram.com/houstonlifetv" class="mr-norm link blue display_flex align_items_center"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="instagram" class="svg-inline--fa fa-instagram fa-w-14 mr-xsm" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512" style="font-size:0.875rem;max-height:0.875rem"><path fill="currentColor" d="M224.1 141c-63.6 0-114.9 51.3-114.9 114.9s51.3 114.9 114.9 114.9S339 319.5 339 255.9 287.7 141 224.1 141zm0 189.6c-41.1 0-74.7-33.5-74.7-74.7s33.5-74.7 74.7-74.7 74.7 33.5 74.7 74.7-33.6 74.7-74.7 74.7zm146.4-194.3c0 14.9-12 26.8-26.8 26.8-14.9 0-26.8-12-26.8-26.8s12-26.8 26.8-26.8 26.8 12 26.8 26.8zm76.1 27.2c-1.7-35.9-9.9-67.7-36.2-93.9-26.2-26.2-58-34.4-93.9-36.2-37-2.1-147.9-2.1-184.9 0-35.8 1.7-67.6 9.9-93.9 36.1s-34.4 58-36.2 93.9c-2.1 37-2.1 147.9 0 184.9 1.7 35.9 9.9 67.7 36.2 93.9s58 34.4 93.9 36.2c37 2.1 147.9 2.1 184.9 0 35.9-1.7 67.7-9.9 93.9-36.2 26.2-26.2 34.4-58 36.2-93.9 2.1-37 2.1-147.8 0-184.8zM398.8 388c-7.8 19.6-22.9 34.7-42.6 42.6-29.5 11.7-99.5 9-132.1 9s-102.7 2.6-132.1-9c-19.6-7.8-34.7-22.9-42.6-42.6-11.7-29.5-9-99.5-9-132.1s-2.6-102.7 9-132.1c7.8-19.6 22.9-34.7 42.6-42.6 29.5-11.7 99.5-9 132.1-9s102.7-2.6 132.1 9c19.6 7.8 34.7 22.9 42.6 42.6 11.7 29.5 9 99.5 9 132.1s2.7 102.7-9 132.1z"></path></svg><span class="font_gibson font_medium color_blue">instagram</span></a></div></div></div></div></div><div style="display:none" id="0fXGD71iDr1" data-fusion-collection="features" data-fusion-type="article/comments" data-fusion-message="Could not render component [features:article/comments]"></div><section class="sponsored-content mb-xlg"><div class="content-block double mb-xlg"><div class="sponsored-content"><section class="content-block"><div id="gmg-outbrain-container"><div class="OUTBRAIN" data-src="https://www.click2houston.com/houston-life/2021/03/29/comedian-michael-yo-coming-home-to-houston-to-headline-shows-at-the-improv/" data-widget-id="AR_3" data-ob-template="click2houston.com"></div></div></section></div></div><div class="content-block mb-xlg"><div class="sponsored-content"><section class="content-block"><div id="gmg-outbrain-container"><div class="OUTBRAIN" data-src="https://www.click2houston.com/houston-life/2021/03/29/comedian-michael-yo-coming-home-to-houston-to-headline-shows-at-the-improv/" data-widget-id="AR_4" data-ob-template="click2houston.com"></div></div></section></div></div><div class="content-block mb-xlg"></div></section></section></main></section><footer class="font_gibson color_black width_full"><div id="fusion-static-enter:0fH6IRQdGrW" style="display:none"></div><div class="linkWrap box_content display_flex mCenter width_max" style="margin-bottom:2.5rem"><ul class="display_grid gap_x_lg gap_y_med no-margin width_full"><li class="font_regular"><a href="https://www.click2houston.com/tv-listings/">TV Listings</a></li><li class="font_regular"><a href="https://www.click2houston.com/contests/">Contests and Rules</a></li><li class="font_regular"><a href="https://www.click2houston.com/account/newsletters/">Email Newsletters</a></li><li class="font_regular"><a href="https://www.click2houston.com/rss/">RSS Feeds</a></li><li class="font_regular"><a href="https://www.click2houston.com/station/2019/11/19/closed-captioning-information/">Closed Captioning</a></li><li class="font_regular"><a href="https://www.click2houston.com/contact/">Contact Us</a></li><li class="font_regular"><a href="https://www.click2houston.com/team/">Meet the Team</a></li><li class="font_regular"><a href="https://www.click2houston.com/careers/">Careers at KPRC</a></li><li class="font_regular"><a href="https://www.click2houston.com/station/2019/11/19/terms-of-use/">Terms of Use</a></li><li class="font_regular"><a href="https://www.click2houston.com/station/2019/11/19/privacy-policy/">Privacy Policy</a></li><li class="font_regular"><a href="https://www.click2houston.com/station/2019/11/19/online-public-inspection-file/">Public File</a></li><li class="font_regular"><a href="/usprivacy/">Do Not Sell My Info</a></li></ul><div class="followUs display_flex justify_space_between mb-xlg "><div class="social"><h6 class="color_black uppercase" style="letter-spacing:0.05em">Follow Us</h6><div class="icons display_flex"><a class="color_black gaevent" href="https://www.facebook.com/KPRC2/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.facebook.com/KPRC2/"><svg aria-labelledby="svg-inline--fa-title-bXtWdAu8OKKI" data-prefix="fab" data-icon="facebook-f" class="svg-inline--fa fa-facebook-f fa-w-10 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 320 512"><title id="svg-inline--fa-title-bXtWdAu8OKKI">facebook</title><path fill="currentColor" d="M279.14 288l14.22-92.66h-88.91v-60.13c0-25.35 12.42-50.06 52.24-50.06h40.42V6.26S260.43 0 225.36 0c-73.22 0-121.08 44.38-121.08 124.72v70.62H22.89V288h81.39v224h100.17V288z"></path></svg></a><a class="color_black gaevent" href="https://twitter.com/KPRC2/" gacategory="Nav" gaaction="Footer Social" galabel="https://twitter.com/KPRC2/"><svg aria-labelledby="svg-inline--fa-title-FlbMXR68s6M8" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><title id="svg-inline--fa-title-FlbMXR68s6M8">twitter</title><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a class="color_black gaevent" href="https://www.instagram.com/kprc2/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.instagram.com/kprc2/"><svg aria-labelledby="svg-inline--fa-title-1w0Fax6La1Gv" data-prefix="fab" data-icon="instagram" class="svg-inline--fa fa-instagram fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><title id="svg-inline--fa-title-1w0Fax6La1Gv">instagram</title><path fill="currentColor" d="M224.1 141c-63.6 0-114.9 51.3-114.9 114.9s51.3 114.9 114.9 114.9S339 319.5 339 255.9 287.7 141 224.1 141zm0 189.6c-41.1 0-74.7-33.5-74.7-74.7s33.5-74.7 74.7-74.7 74.7 33.5 74.7 74.7-33.6 74.7-74.7 74.7zm146.4-194.3c0 14.9-12 26.8-26.8 26.8-14.9 0-26.8-12-26.8-26.8s12-26.8 26.8-26.8 26.8 12 26.8 26.8zm76.1 27.2c-1.7-35.9-9.9-67.7-36.2-93.9-26.2-26.2-58-34.4-93.9-36.2-37-2.1-147.9-2.1-184.9 0-35.8 1.7-67.6 9.9-93.9 36.1s-34.4 58-36.2 93.9c-2.1 37-2.1 147.9 0 184.9 1.7 35.9 9.9 67.7 36.2 93.9s58 34.4 93.9 36.2c37 2.1 147.9 2.1 184.9 0 35.9-1.7 67.7-9.9 93.9-36.2 26.2-26.2 34.4-58 36.2-93.9 2.1-37 2.1-147.8 0-184.8zM398.8 388c-7.8 19.6-22.9 34.7-42.6 42.6-29.5 11.7-99.5 9-132.1 9s-102.7 2.6-132.1-9c-19.6-7.8-34.7-22.9-42.6-42.6-11.7-29.5-9-99.5-9-132.1s-2.6-102.7 9-132.1c7.8-19.6 22.9-34.7 42.6-42.6 29.5-11.7 99.5-9 132.1-9s102.7-2.6 132.1 9c19.6 7.8 34.7 22.9 42.6 42.6 11.7 29.5 9 99.5 9 132.1s2.7 102.7-9 132.1z"></path></svg></a><a class="color_black gaevent" href="https://www.click2houston.com/rss/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.click2houston.com/rss/"><svg aria-labelledby="svg-inline--fa-title-tahtw3oJfFtz" data-prefix="fas" data-icon="rss" class="svg-inline--fa fa-rss fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><title id="svg-inline--fa-title-tahtw3oJfFtz">rss</title><path fill="currentColor" d="M128.081 415.959c0 35.369-28.672 64.041-64.041 64.041S0 451.328 0 415.959s28.672-64.041 64.041-64.041 64.04 28.673 64.04 64.041zm175.66 47.25c-8.354-154.6-132.185-278.587-286.95-286.95C7.656 175.765 0 183.105 0 192.253v48.069c0 8.415 6.49 15.472 14.887 16.018 111.832 7.284 201.473 96.702 208.772 208.772.547 8.397 7.604 14.887 16.018 14.887h48.069c9.149.001 16.489-7.655 15.995-16.79zm144.249.288C439.596 229.677 251.465 40.445 16.503 32.01 7.473 31.686 0 38.981 0 48.016v48.068c0 8.625 6.835 15.645 15.453 15.999 191.179 7.839 344.627 161.316 352.465 352.465.353 8.618 7.373 15.453 15.999 15.453h48.068c9.034-.001 16.329-7.474 16.005-16.504z"></path></svg></a></div></div><div class="omne"><h6 class="color_black uppercase">Get Results with Omne</h6><a href="https://omneresults.com/" target="_blank" rel="noreferrer"><figure class="Box-sc-12ejyki-0 iVNNhU"><div class="Box-sc-12ejyki-0 cUYiQV imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:56px" class="lazyload-placeholder"></div></div></figure></a></div></div></div><p class="no-margin color_black box_content width_max mCenter" style="margin-bottom:3rem;padding:0 1.5rem">If you need help with the Public File, call (713) 778-4745.</p><div class="corporate box_content mCenter width_max"><hr class="width_full regular" style="margin-bottom:3rem"/><div class="display_flex align_items_center width_max"><div class="logos display_flex mb-med"><a href="https://www.grahammedia.com/" target="_blank" rel="noreferrer"><img src="https://www.clickondetroit.com/static-resources/shared/images/gmg_dark.svg" alt="Graham Media Group Logo"/></a><a href="https://hello.grahamdigital.com/" target="_blank" rel="noreferrer"><img src="https://www.clickondetroit.com/static-resources/shared/images/gd_dark.svg" alt="Graham Digital Logo"/></a></div><div class="copyright color_black"><span>Copyright © </span>2021<!-- --> <!-- -->Click2Houston.com<!-- --> <!-- -->is managed by Graham Digital and pubished by Graham Media Group, a division of Graham Holdings.</div></div></div><div id="fusion-static-exit:0fH6IRQdGrW" style="display:none"></div></footer></div><script id="fusion-template-script" type="application/javascript" src="/pf/dist/template/tZiFHy7A1HYkKops/default.js?d=273" defer=""></script><script type="application/javascript">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</script><iframe name="__uspapiLocator" style="display:none" title="__uspapilocator"></iframe><script type="text/javascript" async="" src="//cdn.viafoura.net/vf-v2.js"></script><script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script></body></html>